Infosoft - Certificate Expiration – Incident details

Certificate Expiration

Resolved
Operational
Started 3 months agoLasted about 1 hour

Affected

INFO-Subscription

Partial outage from 9:00 AM to 10:15 AM

Merchant

Partial outage from 9:00 AM to 10:15 AM

API

Partial outage from 9:00 AM to 10:15 AM

Self Service

Partial outage from 9:00 AM to 10:15 AM

Third Party Services

Operational from 9:00 AM to 10:15 AM

Third Party: Auth0 → Europe (PROD) → Auth0 Machine to Machine Authentication

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    This morning at roughly 11:00 CET, the certificate used to encrypt traffic to/from the API for INFO-Subscription expired.

    This caused interactions between our UI applications (Self-Service and Merchant) to be affected, as well as any third party integrations that verify the certificate properly when interacting with the API.

    The certificate was replaced with a valid one around 11:45 CET and everything is back to normal.

    Ordinarily the certificate is automatically replaced with a working certificate a month prior to the expiration. This time around, the tooling we rely on for replacing the certificate did not replace it. The altert for the missing new certificate was handled, but unfortunately we were not aware of extra actions needed to replace the certificate at that time.

    We apologize for any issues this may have caused.