Infosoft - Issue with ordering using Vipps via the Salesposter – Incident details

Issue with ordering using Vipps via the Salesposter

Resolved
Partial outage
Started about 1 year agoLasted about 21 hours

Affected

INFO-Subscription

Partial outage from 12:31 PM to 9:18 AM

Self Service

Partial outage from 12:31 PM to 9:18 AM

Updates
  • Update
    Update

    We are in the process of rolling out a more permanent solution to the previous incident.

    It will be deployed throughout the day for all tenants.

  • Resolved
    Resolved

    No new occurence of the issue has been observered since the fix was deployed.
    Everything is operational again.

    We will deploy an application fix at a later time as a more permanent solution.

    Updated Analysis/Description of the Issue:
    The initial assumption that the cause was due to an underlying Azure reconfiguration was only partially correct.

    The Azure reconfiguration happened 3 months ago, enforcing the URL limit to become 2048 chars (which is documented default, so basically they fixed a bug).
    This did not immediately have any effect.

    On January 9th, Vipps deployed a change causing their order/agreement draft response to contain additional characters. For some tenants, this tipped the generated URLs above the 2048 character limit.

    Our current solution has been to reconfigure the limit, but we are working on a more permanent solution where such changes to third parties will not interrupt the workflow again.

    Sorry for any inconveniences this may have caused.

  • Monitoring
    Monitoring

    We implemented a temporary configuration fix and are currently monitoring the effects.

  • Update
    Update

    We are continuing to work on a fix for this incident.

    We are in contact with Microsoft to have them revert the configuration (or adjust it), at the same time we are working towards an application fix to circumvent the issue entirely.

  • Identified
    Identified

    We have identified the issue as an undocumented change in underlying Azure infrastructure.

    The change has restricted URLs to 2048 characters in length.

    For tenants with long product and package names and descriptions will end up with a Vipps order confirmation URL that is longer than those 2048 characters.

    A temporary workaround is to reduce the Name and Description as much as possible on the subscription plan.

    We are working with Microsoft to increase the limit, and at the same time have started work on an application fix to reduce the length for our generated URLs.

  • Investigating
    Investigating

    We are currently investigating an incident where Vipps orders returns an error reporting that the resource was not found or moved.

    Orders using other types of payment providers still work as expected.