Infosoft - Checkout not functioning – Incident details

Checkout not functioning

Resolved
Operational
Started 6 days agoLasted 27 minutes

Affected

INFO-Subscription

Partial outage from 10:40 AM to 10:52 AM, Operational from 10:52 AM to 11:07 AM

Self Service

Partial outage from 10:40 AM to 10:52 AM, Operational from 10:52 AM to 11:07 AM

Updates
  • Postmortem
    Postmortem

    A reconfiguration of the main API related to security hardening was done on the 6th of August around 9.00 CEST.

    This reconfiguration cuased the Orders API to only be granted access to a few tenants, due to a human configuration error of the permissions.

    Adding the required permission to affected tenants immediately resolved the issue and allowed the Order API to communcate with the main API as expected.

    Unfortunately the error was not discovered beforehand, because the tenants used in surveillance testing were allowed access. Additionally the type of API error emitted is a common error type when consumer requests data without sufficient permissions.

    We will investigate how to avoid such issues in the future. Sorry for any inconveniences this may have caused.

  • Resolved
    Resolved

    This incident has been resolved. All checkout and order api related operations are functioning as expected.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We are currently investigating an incident causing checkout processes to be non-functional.